Vejledninger

Sådan rettes Kunne ikke finde en version, der opfylder kravene til Tensorflow

Tensorflow er en open source-platform for kunstig intelligens, og den består af omfattende biblioteker og samfundsmæssige ressourcer, der lader forskere skubbe den nyeste teknologi inden for Maskinelæring og ingeniører fremstiller og integrerer effektivt ML-kontrollerede applikationer på mikrokontroller og mikroprocessorer. Computernørene er i stand til nemt at installere Python og PyCharm på deres systemer, men når de prøver at installere Tensorflow, støder de på fejlmeddelelsen: “Kunne ikke finde en version, der opfylder kravet TensorFlow (fra versioner:) Ingen matchende distribution fundet for TensorFlow”. Mange mennesker har installeret Flask for at slippe af med dette problem, men de er ikke i stand til at holde dette i betragtning. Jeg har samlet nogle mulige løsninger på dette problem og følg denne vejledning igennem for at slippe af med denne fejl.

Som det viser sig, er der flere forskellige årsager, der muligvis ender med at forårsage dette problem, lad os gå et skridt videre og teste nogle rettelser, indtil vi er i stand til at fjerne denne fejl på Windows.

Metode 1: Bekræft Python-version på dit system

Hvis du kører Windows 10 med Python 3.6.X version på dit system, ville Python-32 bit version sandsynligvis have kørt på 64bit maskine. Husk en ting, at TensorFlow kun er kompatibel med 64bit installation af python og ikke 32bit version af python. Hvis du har downloadet Python fra python.org, ville standardinstallationen være 32 bit, så download et 64bit-installationsprogram herfra for at slippe af med dette problem. Nu skal vi indstille STImiljøvariabel, fordi den viser de mapper, der skal søges efter eksekverbare filer, når du skriver en kommando i kommandoprompten. Ved at tilføje stien til den Python-eksekverbare fil kan du få adgang python.exe ved at skrivepython søgeord (du behøver ikke at angive den fulde sti til programmet). Hvis PATH-variablen ikke er indstillet, opstår følgende fejl:

C: \> python 'python' genkendes ikke som en intern eller ekstern kommando, et operativt program eller en batchfil.

Som du kan se, at kommandoen ikke blev fundet, kører den derfor python.exe, skal du angive den fulde sti til den eksekverbare, og derfor skal du angive den fulde sti til variablen, skal du følge trinnene indekseret nedenfor:

  1. Højreklik på Denne computer, og klik derefter på Ejendomme knap.
  2. På venstre side af vinduet skal du kigge efter avancerede systemindstillinger, og efter at have klikket på det, vil du observere det Systemegenskaber Vinduet åbnes.
  3. Se nu efter PATH-variabelindstilling, og klik på Redigere. Placer markøren i slutningen afVariabel værdi linje og tilføj stien til filen python.exe forud for semikolontegnet (;). I mit tilfælde har jeg tilføjet følgende værdi: C: \ Python36, fordi jeg vil køre Python 3.6 version.
  4. Luk alt Windows, og søg efter kommandoprompt. Skriv følgende kommando i kommandovinduet og tryk enter. Du ser, at nu er 64bit-versionen til stede på dit system, og nu prøver jeg at installere TensorFlow og kontrollere, om fejlen stadig er der eller ej:
    C: \> python - version Python 3.7.6 (standard, 8. jan 2020, 20:23:39) [MSC v.1916 64 bit (AMD64)]
  5. Kør følgende kommando for at installere TensorFlow på dit system, og forhåbentlig fortsætter installationen nu uden nogen fejlmeddelelse. Bemærk:TensorFlow er endnu ikke i PyPI-arkivet, så du skal angive URL'en til den passende "hjulfil" til dit operativsystem og Python-version.
    pip-installation --upgrade //storage.googleapis.com/tensorflow/mac/cpu/tensorflow-0.12.0-py3-none-any.whl

Metode 2: Nedgradere din Python-version på Anaconda

Tensorflow understøtter kun Python 3.6.x og kun 64bit-versionen. Derfor, hvis du kører GUI, ligesom anaconda og python 3.7 er installeret som standard på det, er vi derfor nødt til at nedgradere det til 3.6 for at installere Tensorflow. For at udføre denne opgave skal du køre kommandoerne, der er angivet nedenfor på din Anaconda-prompt:

 conda installere python = 3.6.4 

Efter at have kørt denne kommando, vent et par sekunder, og opret derefter et virtuelt miljø til installation af Tensorflow. Navngiv det virtuelle miljø såsom “ab” og installer derefter den aktuelle udgivelse af CPU-kun TensorFlow:

 conda create - n ab tensorflow conda aktiver tf 

Efter nedgradering af din python-version vil Tensorflow nu blive installeret uden at der vises nogen fejl, og selvom du har installeret Desktop-versionen af ​​Ubuntu, fungerer den også for det.

Metode 3: Opdater pakkeinstallationsprogrammet til Python

Pip er pakkeinstallationsprogrammet til Python, og vi kan bruge pip til at installere pakker fra Python Package Index og andre indekser. Selvom opdateringer frigives regelmæssigt efter tre måneder, og disse pakker skal opdateres manuelt på dit system ved at køre bestemte kommandoer. Hvis disse ikke er forældede, kan de forårsage denne Tensorflow-installationsfejl, derfor opdaterer vi pip-pakken ved at køre følgende kommandoer nedenfor, så alle pakkerne opdateres automatisk:

pip-installation --opgradering pip-pipinstallation --upgrade //storage.googleapis.com/tensorflow/mac/cpu/tensorflow-0.12.0-py3-none-any.whl

Efter opdatering af pip-pakker forhåbentlig kører din installation problemfrit, og du kan udvikle interessante programmeringsprojekter ved hjælp af Tensorflow nu.

Løsning:Der er muligvis ikke en version af TensorFlow, der er kompatibel med din version af Python. Dette gælder især, hvis du bruger en ny udgivelse af Python. For eksempel kan der være en forsinkelse mellem frigivelsen af ​​en ny version af Python og frigivelsen af ​​TensorFlow for den version af Python. I dette tilfælde tror jeg, at de ovennævnte muligheder som nedgradering til den tidligere version af Python, kompilering af TensorFlow fra kildekoden og venter på, at en matchende version af TensorFlow frigives, er alle mulige løsninger, der kan give dig mulighed for at installere Tensorflow på dit system uden fejl.