Vejledninger

Fix: .NET Framework 4.7 understøttes ikke på dette operativsystem

.Net Framework er en programmeringsinfrastruktur, der er introduceret af Microsoft. Du skal bruge .Net Framework til at køre forskellige applikationer og tjenester. De fleste af de applikationer, der kræver .Net Framework, leveres også med sine installationsfiler. Så det installeres automatisk på dit system, når du installerer et program. Men du kan muligvis se en fejl “.NET Framework 4.7 understøttes ikke på dette operativsystem”, når du installerer et program. Denne fejl forhindrer dig i at installere applikationen. Du kan muligvis se denne fejl, når du prøver at installere .Net Framework som et enkeltstående program / en tjeneste.

Årsagen til, at denne fejl opstår, er den samme som nævnt i fejlmeddelelsen. Selvom .Net Framework understøttes på Windows 10, men det er ikke kompatibelt med alle versioner af Windows 10. Så hvis du ser denne meddelelse, er den mest sandsynlige årsag til denne fejl, at du kører en Windows 10-version, der er ikke kompatibel med .Net Framework.

Metode 1: Opdater Windows 10

Den eneste løsning på dette problem er simpelthen at opdatere din Windows 10. Det tilrådes at kontrollere Windows-opdateringer, selvom du er på den nyeste version af Windows 10. Da problemet skyldes et inkompatibelt operativsystem, skal du installere alle de tilgængelige Windows 10 opdateringer vil sandsynligvis løse problemet. Du kan også kontrollere den nøjagtige version af din Windows 10 og den version, der kræves af .Net Framework, ved at følge nedenstående trin.

  1. Holde Windows-nøgle og tryk på R
  2. Type Winver og tryk på Gå ind

  1. Din version skal nævnes i det nyligt åbnede vindue. Nummeret efter versionen (i anden linje) er dit versionsnummer. Tallet skal være 1507 eller 1709. De første 2 cifre er året, og det andet 2 repræsenterer måneden. Så hvis du har en 1709-version, betyder det, at du kører en version, der blev frigivet i september 2017

  1. Nu skal du sørge for, at du har den Windows 10-version, der er kompatibel med .Net Framework. Klik på her og klik på Systemkrav

Hvis du ser på Understøttet operativsystem sektion, står der Windows 10-jubilæumsopdatering og Windows 10 Creators-opdatering. Da mange mennesker ikke er bekendt med de versionsnumre, der er knyttet til jubilæums- og skabereopdateringerne, har vi nævnt dem nedenfor

  • Opdatering fra november (1511)
  • Jubilæumsopdatering (14393)
  • Skabereopdatering (1703)
  • Fall Creators Update (1709)
  • Spring Creators Update (1803)

Som du kan se, har jubilæumsopdateringen versionsnummeret 14393, og skabereopdateringen har en version 1703. Så hvis du har en version lavere end 14393, kan du ikke installere .Net Framework 4.7 på Windows 10. Nu skal du blot opdatere Windows og sørge for, at du har den nyeste Windows 10-version, og prøv igen.